Technical Requirements

System Requirements

Florida Virtual School technology and courses make use of a wide variety of features and technologies, such as Java, Flash, HTML5, CSS2/3, and depending on the course, other specialized components that help you achieve a more immersive learning experience.

Some courses may have different or additional requirements to the one listed on this page. For specific System Requirements for your course, go to the Material List page in the Course Information tab within the course.

Supported Operating Systems

  • Windows 7
  • Windows 8.1
  • Windows 10
  • Mac OS X 10.7 (Lion)
  • Mac OS X 10.8 (Mountain Lion)
  • Mac OS X 10.9 (Mavericks)
  • Mac OS X 10.10 (Yosemite)
  • Mac OS X 10.11 (El Capitan)
  • macOS Sierra (10.12)

Supported Browsers

You may use recent versions of the following browsers on a technology capable device that supports Java, Flash, and improvements to HTML including HTML5.

  • Microsoft Internet Explorer 11
  • Microsoft Edge
  • Mozilla Firefox
  • Google Chrome
  • Apple Safari

Supported Browser Plugins and Settings

The following plugins and settings may be required to use our courses.

  • JavaScript enabled
  • Cookies enabled
  • Flash enabled
  • Java installed

Mobile Device Requirements

Due to the wide array of technologies in our over 100 courses, there are some limitations to browsers and devices we can support. At present, we test and verify a wide variety of devices and have ongoing programs to migrate away from any technologies that are not compliant with newer mobile platforms. In general however, lightweight devices such as Google Chromebooks or tablets that have very limited technology support for Java or Flash, will not be compatible with the majority of our courses. Please ensure you have a Windows or Mac based computer available to complete coursework in the event that your selected mobile device does not meet the needs of the course.

  • 7″ or larger display size
  • Access to WiFi with a high speed internet connection (4G or LTE connections are supported, but you may incur costs based on your mobile data plan)
  • Method to save work to local or cloud storage
  • Minimum Operating System: iOS 6 or greater, Android 2.2 (Froyo) or greater, Windows Phone 7.5 or greater

Is your web browser up to date?

Below is the browser setup you are using. Please confirm the supported browser, plugins and settings are installed and configured.

Your experience and satisfaction will vary platform to platform. If you see issues in your course content or presentation/layout, please try a different browser or device.

If you have questions or need help, please visit http://help.flvs.net.

Are you ready to get started?Enroll Now